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Legal notice

The use of the software, described in this documentation, is governed by the terms of the end user license agreement,
which accompanies such software.

1. Copyrights and rights of use:

The software and accompanying documentation are the copyrighted work of ORMETIS SAS. Use of the software and
the documentation is therefore governed by the terms of the license agreement, which accompanies the software. In the
event no license accompanies this documentation, the content of this document is protected by the the French Intellectual
Property Code.

© 2009 ORMETIS SAS. All rights reserved.

This document may not, in whole or in part, be photocopied, reproduced, translated, or reduced to any electronic medium
or machine readable form without prior consent, in writing, from ORMETIS SAS.

2. Warranties and disclaimers:

This documentation is provided “AS IS” without any warranty of any kind, expressed or implied, and therefore, may
include technical or typographic errors, omissions or other inaccuracies. ORMETIS SAS assumes no responsibility for
errors or omissions in this document.

Information in this document is subject to change without notice and does not represent a commitment on the part of
ORMETIS SAS.

3. Update:

This documentation relates to the version of the software, with which it is distributed. Updates of the software may be
made without any modification to this document.

4. Trademarks:

Ormetis, Ormetis logo and Ormetis Professional Edition are either registered trademarks or trademarks of ORMETIS
SAS.

Microsoft, Excel, Windows and Windows logo are either registered trademarks or trademarks of Microsoft Corporation.

All other trademarks are property of their respective owners.
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Introducing Ormetis Professional Edition

What can you do with Ormetis Professional Edition?

Ormetis Professional Edition allows you to import data in different formats and from different sources, combine it,
transform it, and export the result in a format of your choice. You can use Ormetis Professional Edition, for example,
to import related data from several text files and an Excel spreadsheet. You combine the data on common elements,
transform it (for example, by grouping, filtering, rotating or sorting it), then export the result to a different Excel
spreadsheet or text file.

Ormetis Professional Edition handles the details of data transformation and formatting seamlessly. For example, when
you combine data from different sources, Ormetis Professional Edition automatically recognizes if the data uses different
date or number formats and applies a common format to the combined data. (You can change this format later if
you choose.) Ormetis Professional Edition also recognizes when the first line in a file contains column names, and
automatically distinguishes different separator characters in comma-separated values (CSV) files.

With Ormetis Professional Edition, you can concentrate on the meaning of your data rather than on its formatting or on
the mechanics of transforming it. You can build complex, repeatable and auditable transformation processes without
technical knowledge or help from your IT department.

How do you work with Ormetis Professional Edition?

You import, combine, transform and export data in Ormetis Professional Edition by building a data transformation
scenario. A scenario contains views which represent intermediate stages of your data as you move toward your target
data format. When you add a step to the scenario, you transform data in an existing view to create a new view which
you can further transform with additional steps. You create new views, for example, by grouping, stacking, rotating,
sorting or filtering existing views.

A data transformation scenario can be complex, containing many steps and views. When you arrive at the view
containing your target data format, the final step is to export its data to an external file.

You can build scenarios for one-off data transformations. You can also save scenarios, making the whole process of
import, combination, transformation and export reusable. Scenarios respond to changes in your source data and even to
the addition of new source files by updating the data they output.

Data transformation scenarios replace time-consuming and error-prone traditional methods of data manipulation and
transformation like copy and paste. They remove the need for programming and IT involvement by making complex,
repeatable and flexible data transformations available through a simple user interface to non-technical users.
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Working with Ormetis Professional Edition

Selection and scope

The effect of an action carried out in Ormetis Professional Edition often depends on which view, part of view or data
you select when performing the action. The impact of actions is both selection- and data-driven.

For example, if you select the grouping control in a grouped view, and then sort data in ascending order, Ormetis
Professional Edition applies the sort to the rows in the grouping control. If you select a column within a grouped view
and apply an ascending sort, Ormetis Professional Edition sorts the data in all groups in ascending order according to
the column values.

When you change the data in a view, the extent of the change is data- and selection-driven. For example, if you replace
the text "Jacket" in a cell in the Product column, Ormetis Professional Edition replaces all cells in the Product column
containing the string "Jacket". If you select rows 4, 5 and 6 and replace the "Jacket" text in row 4, Ormetis Professional
Edition modifies the text in rows 4, 5 and 6, but not in other cells containing the same text.

If you replace text in a grouping control, the replacement applies to the group header. For example, if you replace the
text "Jacket"with "Coat" in a grouping control, and then ungroup the view, the grouping column contains "Coat" in all
rows where its value was previously "Jacket".

Building scenarios

Introduction to scenarios

You transform data by building data transformation scenarios. Scenarios contain all the actions you perform to transform
your data. These actions appear as steps, listed from top to bottom in the Scenario pane at the right of the Ormetis
Professional Edition interface. Selecting a step allows you to view a snapshot of the scenario at the point represented
by the step.

A scenario usually consists of data import steps, followed by data transformation steps, followed by data export steps
to write your transformed data to external files in your target format. A scenario provides a repeatable chain of actions
for transforming your data, and updates its exported data in response to changes in your source data.

To create scenarios

Click the Ormetis button , then click New.
The Scenario pane and View pane appear blank.

To open scenarios

1.

Click the Ormetis button , then click Open.
2. Browse to the scenario you want to open, select it and click Open.

Note:  Scenario files have the ORM file extension.

To save scenarios

1.

Click the Ormetis button , then click Save or Save As.
2. If you clicked Save As or if you are saving the scenario for the first time, type the name of the scenario, then click

OK.
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Note:  Ormetis Professional Edition saves scenarios with
the ORM file extension.

Steps and scenarios

Steps are Ormetis Professional Edition's way of visualizing and ordering the actions you perform in a data transformation
scenario. Whenever you perform an action, a corresponding step appears in the Scenario pane on the right of the Ormetis
Professional Edition interface. Steps display from top to bottom in the Scenario pane.

You can also work with the steps in the Scenario pane to interact with a scenario. For example, you can change the
name of a view by double-clicking its name in a step, then typing the new view name.

Steps represent an action performed on one or more existing views or on an external file to output a new view. The text
of the step has three elements: the name of the output view (View#n by default, or the name of an external file), the
action, and the input views or file. For example, if you sort the data in ascending order on the Ticker column in a view
called Companies, the text of the step is View#n Sort AZ Companies.

When you select a step in the Scenario pane, you see a snapshot of the scenario in the View pane at the point in the
scenario corresponding to the step. For example, if the step Sales Import File Sales.txt is the first step in
a scenario, you see the Sales view only in the View pane when you select the step.

You can perform actions on views displayed in a snapshot of a scenario even if the step you selected is not the most
recent step. The new step corresponding to the action you perform appears at the end of the scenario.

Importing files

To import files

1. Click Home ➤ Import ➤ File.

2. Select the files you want to import and click Open.

The views corresponding to the imported files appear in the View pane and the steps corresponding to the import
actions appear in the Scenario pane. Each step appears as <view-name> Insert File <file-name>.

Each view contains two columns in addition to the columns in the file: a column showing the view name which
displays the row number, and a File column repeating the name of the file on each row.

If the imported file is an Excel spreadsheet with worksheets, the view appears as a grouped view, and the grouping
control at the left of the view contains a group for the name of each worksheet.

Importing files from folders

You can import multiple files from a folder by multiple selection of all the files. You can also select the folder containing
the files.

Selecting the folder has a clear advantage. When you select the folder, Ormetis Professional Edition creates a grouped
view. Each group represents the data imported from one file. If you add files to the folder, Ormetis Professional Edition
automatically updates the grouped view to account for the new files.

Importing files from a folder

In this example you have a folder containing files with orders from different stores. Each file
is named <store-location>.txt, for example Boston.txt. Each file contains four
columns: Reseller, Delivery, Quantity and Product.

When you select the folder, the following grouped view appears in the View pane.
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The groups are derived from the names of the files in the folder. You add a new file, San
Francisco.txt, to the folder. This file contains similar data for the San Francisco store.
Ormetis Professional Edition automatically updates the grouped view with an additional group for
San Francisco.

To import files from folders

1. Select Home ➤ Import ➤ Folder.

2. Select the folder containing the files you want to import and click OK.
Ormetis Professional Edition creates a grouped view from the files in the folder.

Working with views

Managing views

To rename views

1. Select the view you want to rename in the View pane.

2. Click Home ➤ Views ➤ Rename.

3. Type the new view name in the top left cell of the view.

Note:

• When you rename a view, the view name also
changes on all steps that reference the view.

• You can also rename a view by double-clicking its
name in the corresponding step, then typing the new
name.

To duplicate views

1. Select the view you want to duplicate in the View pane.

2. Click Home ➤ Views ➤ Duplicate.
Ormetis Professional Edition creates a duplicate of the view in the View pane.
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To close views

1. Select the view you want to close.
2. Click Home ➤ Views ➤ Close.

The view no longer appears in the View pane.

To change the regional settings of views

1. Select the view whose regional settings you want to change in the View pane.
2. Click Home ➤ Locale ➤ Regional Settings and select the locale from the list.

Note:  When you stack views, the regional settings from
the top view apply to the stacked view.

Managing columns and rows
To rename columns

1. Select the header of the column you want to rename.
2. Click Home ➤ Columns & Rows ➤ Rename.
3. Type the new column name in the column header.

To delete columns and rows

1. Select the column headers of the columns you want to delete and the row numbers of the rows you want to delete.

Note:  You can select column headers only or row
numbers only if you want to delete columns only or rows
only.

2. Click Home ➤ Columns & Rows ➤ Delete.
Ormetis Professional Edition deletes the columns and rows you selected from the view.

To extract columns and rows

1. Select the column headers of the columns you want to extract and the row numbers of the rows you want to
extract.

Note:  You can select column headers only or row
numbers only if you want to extract columns only or
rows only.

2. Click Home ➤ Columns & Rows ➤ Extract.
Ormetis Professional Edition deletes all columns and rows other than the ones you selected from the view.

Combining views

Stacking views

You stack views by placing one view on top of another to create a new view.

A stacked view takes its regional settings by default from the upper view in the View pane. For example, if the upper
view has dates in US format (mm/dd/yyyy), dates in the stacked view appear in mm/dd/yyyy format.

Note:  You can change the regional settings of any view
by selecting the view, then selecting Views ➤ Locale ➤
Regional Settings.

A stacked view contains a column for each unique column in the original views. If the original views contain columns
with the same name, the stacked view combines their data in a column with the same name. If a column does not appear
in all the original views, its data appears blank in the rows corresponding to the views where the column did not exist.

To stack views

1. Select the first view.
2. Hold down the Control key.
3. Select the second view.
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4. Select Data ➤ Combine ➤ Stack from the menu.

Note:  You can also stack views by dragging and
dropping the lower view over the upper view.

• The upper view in the View pane is stacked on top of the lower view.
• The regional settings (for example, the date format) from the upper view are applied to the combined view.
• The combined view contains one column for every column in the upper and lower views. If a column has the

same name in both views, it appears as a single column in the combined view. If a column did not exist in all
the original views, its values appear blank in the rows corresponding to the views where it did not exist.

• A step, Stack <upper-view> on <lower-view> appears in the Steps pane.

Matching views

You match views by placing them side by side to create a new view based on values in a common column.

Matching views

In this example you match two views. The first view contains product information.

The second view contains product prices.

When you match the views, Ormetis Professional Edition automatically recognizes the common
column, Product.

Ormetis Professional Edition does not include row 4 from the view containing the prices because
there is no matching product in the view containing the products.

Note:  Ormetis Professional Edition
recognizes common columns even
when the name of the common
column is not the same in both views,
by matching on data values.

To match views

1. Select the first view you want to match.

2. Hold down the Control key.
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3. Select the second view you want to match.
4. Click Data ➤ Combine ➤ Match.

Ormetis Professional Edition matches the views on common columns.

Attaching views

You attach views by placing them side by side to create a new view. If it is possible to match the data on a common
column, Ormetis Professional Edition performs a match.

Attaching views is different from matching views in two ways:

• If data cannot be matched on a common column, data from both views appears unmatched in the new view.
• Ormetis Professional Edition does not recognize common columns when the column names are different.

Attaching views

In this example you attach two views. The first view contains product information.

The second view contains product prices.

When you attach the views, Ormetis Professional Edition automatically recognizes the common
column, Product.

Ormetis Professional Edition includes row 4 from the view containing the prices. The columns
displaying data from the product view are blank because there is no corresponding data in that view.

To attach views

1. Select the first view.
2. Hold down the Control key.
3. Select the second view.
4. Click Data ➤ Combine ➤ Attach.

Ormetis Professional Edition attaches the views and matches the data on common columns where possible.

Transforming data

Sorting data

To sort data

1. Select the column you want to use to sort the data. (You can also select the grouping control in a grouped view to
apply the sort to the grouping values.)
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2. Click Data ➤ Sort & Filter ➤ Sort A-Z to sort the data in ascending order, or Sort Z-A to sort the data in
descending order.

Note:  If you selected the grouping control in a grouped
view, Ormetis Professional Edition applies the sort to the
values in the grouping control. If you selected a column
in the view, Ormetis Professional Edition applies the sort
to the column.

Filtering data

You can filter the data in a view by removing rows based on the values in columns. You can also remove rows containing
empty or duplicate values.

To keep rows
1. Select the cells containing the values you want to use to keep rows.
2. Click Data ➤ Sort & Filter ➤ Keep Rows.

Ormetis Professional Edition removes all rows where the columns containing selected cells do not have the values
in the selected cells.

For example, if you selected cells in the City column containing the values "Los Angeles" and "San Diego", Ormetis
Professional Edition removes all rows where the value of City is not "Los Angeles" or "San Diego".

To remove rows
1. Select the cells containing the values you want to use to remove rows.
2. Click Data ➤ Sort & Filter ➤ Remove Rows.

Ormetis Professional Edition removes all rows where the selected columns have the values in the selected cells.

For example, if you selected cells in the City column containing the values "Los Angeles" and "San Diego", Ormetis
Professional Edition removes all rows where the value of City is "Los Angeles" or "San Diego".

To remove duplicate rows

You can remove duplicate rows where the values in the columns you select are duplicated. When you remove duplicates,
Ormetis Professional Edition retains the first row in the set of duplicates and filters out the other rows. The order of the
data in the view is crucial in determining which rows are kept.

1. Select the columns that you want to test for duplicate values.
2. Click Data ➤ Filter ➤ Remove Duplicate Rows.

Ormetis Professional Edition removes all rows containing duplicate values in the columns, apart from the first row
in the set.

To remove empty rows

You can remove rows which contain empty values in the columns you select.

1. Select the columns you want to test for empty values.
2. Click Data ➤ Sort & Filter ➤ Remove Empty Rows.

Ormetis Professional Edition removes all rows containing empty values in the selected columns.

Grouping data

Grouping views

You group views by selecting a column that you want to use to group the data in the view. When you group the data,
Ormetis Professional Edition removes the grouping column from the view and displays its unique values in the grouping
control to the left of the view. When you select a value in the grouping control, the view displays all rows where the
grouping column had the selected value.

The image displays a grouped view with a grouping control.
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To group views

1. Select the column you want to use to group the data.

2. Click Data ➤ Organize ➤ Group.
The view becomes a grouped view. The grouping control to the left of the view displays the values in the column
you selected. When you click a value in the grouping control, the group displays all the rows relating to the value.

Slicing views

You use slicing to group data which is stored horizontally rather than vertically. For example, in the following view,
the first column describes the data, and the second column contains the data values.

If you slice the data on the first column, Ormetis Professional Edition groups it into two groups by identifying repeated
values in the slicing column. In this example, the value "Reseller" repeats on row 5, causing Ormetis Professional Edition
to create a new group starting on that row. The data in the group is sliced as shown below.

Note:  Slicing is typically one of the steps you perform when
transforming a horizontal view of data to a vertical view.

To slice views

1. Select the column used to slice the data.

2. Click Data ➤ Organize ➤ Slice.
Ormetis Professional Edition slices the view according to the sets of unique values in the slicing column. The
groups appear as Group <group-number> in the grouping control.
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To ungroup views

1. Select the grouped view you want to ungroup.
2. Click Data ➤ Organize ➤ Ungroup.

Ormetis Professional Edition removes the grouping control from the view and adds a Group column containing its
values to the view.

Merging and splitting columns

To merge columns

1. Select the columns you want to merge.
2. In the Home ➤ Format ➤ Merge With menu item, select Tab to merge the columns with tab characters, or click

String and type the string used to merge the columns.
3. Click Merge With.

Ormetis Professional Edition merges the columns into a single column with values corresponding to the original
column values. These values are separated by the string you specified.

To split columns on characters

1. Select the column whose data you want to split into separate columns.
2. In the Home ➤ Format ➤ Split On  menu item, click Tab to split the data on tab characters, Space to split the

data on spaces, or type the splitting character in the box.
You can specify more than one splitting character. For example, if you select Tab and Space and you type ";" in
the box, Ormetis Professional edition splits the data into a new column at every tab, space or ";" character.

To split columns at a character position

1. Select the column you want to split.
2. In the Home ➤ Format ➤ Split At menu item, type the character position at which you want to split the column

data into new columns.
3. Click Split At.

Ormetis Professional Edition splits the data into columns at every n characters, where n is the number you
selected.

Defining headers

You can move data between column and row headers in four ways.

Operation Description

Define columns as headers You select a column and move its values to the
corresponding row headers

Define rows as headers You select a row and move its values to the
corresponding column headers

Define headers as columns You move the values in the row headers into the
view data

Define headers as rows You move the values in the column headers into
the view data

To define columns as headers

1. Select the columns you want to define as a row headers.
2. Click Home ➤ Headers ➤ Columns as Header.

Ormetis Professional Edition moves the values in the columns you selected to the row headers. (The row headers
are the vertical headers on the left of the view that normally contain the row numbers.)
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To define rows as headers

1. Select the rows you want to define as column headers.

2. Click Home ➤ Headers ➤ Rows as Header.
Ormetis Professional Edition moves the values in the rows you selected to the column headers.

To define headers as columns

1. Select the cell at the top of the row headers.

2. Click Home ➤ Headers ➤ Header as column.
The data in the row headers becomes a column in the view.

To define headers as rows

1. Select the column headers.

2. Click Home ➤ Headers ➤ Header as Row.
The data in the column headers becomes the data in a row.

Flipping and rotating data

To flip row and column data

By flipping row or column data, you reverse the order of the data.

1. Select the view whose columns or rows you want to flip.

2. Click Data ➤ Transform ➤ Flip Columns  to flip columns or Data ➤ Transform ➤ Flip Rows  to flip rows.

Flipping columns and rows

A view displays the following data:

If you flip the columns, the data appears as follows:

If you flip the rows, the data appears as follows:
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To rotate data in views

When you rotate a view you rotate its data through 90 degrees. The data headings move between column headers and
row headers to identify the rotated data.

1. Select the view.

2. Click Data ➤ Transform ➤ Rotate.
Ormetis Professional Edition rotates the data in the view through 90 degrees.

Rotating a view

A view contains the following data:

After rotation, the data is as follows:

Because the delivery dates now appear across row 1, quantities across row 2, and products across
row 3 (all from right to left), the column headers become row headers to identify the rotated data.

If you rotate the data again, the headers again become column headers to identify the rotated data
by column.

Replacing data in cells

To replace data in cells

1. Select the cell whose data you want to replace.

2. Select rows to if you want the data replacement to apply to specific rows only.

If you do not select any rows, Ormetis Professional Edition replaces the data in all cells whose values correspond
to the value you selected.

3. Click Data ➤ Sort & Filter ➤ Replace All and type the replacement text in the cell.

Replacing text in cells

In the following view you select rows 1 and 2 and replace the "Jacket" text in the Product column
with "Coat".
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Ormetis Professional Edition replaces the data as follows:

In the same view, you replace the "Jacket" text with "Coat" in any cell in the Product column, and
without selecting any rows. In this case, Ormetis Professional Edition changes the values in all the
cells to "Coat".

Exporting data

To export data from views

1. Select the view for data export.

2. Click Home ➤ Views ➤ Export

3. Select the export format. The export formats are displayed in the table.

Format Description

Excel 97-2003 Ormetis Professional Edition saves the data
as an Excel 97-2003 (XLS) workbook. If the
view is a grouped view, each group appears
as a worksheet.

Excel Ormetis Professional Edition saves the data
as an Excel 2007 (XLSX) workbook. If the
view is a grouped view, each group appears
as a worksheet.

Text Ormetis Professional Edition saves the data in
text format, with columns separated by semi-
colons (;).

Ormetis Ormetis Professional Edition saves the view
as the only view in a new scenario (ORM)
file. The view and the scenario have the same
name.
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Examples of data transformations

Transforming horizontal data to vertical data

In this example you have a view created by importing a file that stores data stored horizontally rather than vertically.

The first column in the file describes the data and the second column provides the data value. For example, row 1 says
that the value of "Reseller" is "The Clothes Store".

You want to store this data in a more traditional vertical format, with the values in the first column as column headers,
and the values in the second column as column values. This gives the following result:

To transform the data in this way, you need to perform the following tasks:
• Slice the data on the first column to create a grouped view
• Rotate the view
• Define the first row as the header
• Ungroup the view
• Delete the grouping column
• Flip the columns

Slicing the data on the first column

By slicing the data, you create groups based on repeating values in the slicing column. When Ormetis Professional
Edition encounters the value "Reseller" for the second time in row 5, it groups the view in four-row groups.
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Rotating the view

By rotating the view, you move the data through 90 degrees. Now when you select Group 1 in the grouping control,
the data appears as follows:

Defining the first row as the header

By defining the first row as the header, you move its values into the column headers. Now when you select Group 1,
the data appears as follows:

Ungrouping the data

By ungrouping the data, you remove the grouping control from the view and insert a column containing the grouping
values.

Deleting the grouping column

By deleting the grouping column, you retain only the columns you want. They remain in the wrong order.

Flipping the columns

By flipping the columns, you put the columns in the order you want.
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Glossary

Term Definition

Attaching Placing one view alongside another to create a
new view. The resulting view contains all data
from both views even when there is no matching
value in a common column.

Combining Creating a new view by attaching or matching
existing views.

Exporting Writing data from a view to an external file, for
example a CSV or Excel file.

Grouped view A view in which the data has been grouped on
the values in a column, or sliced on sets of unique
values in a column. Groups appear in a grouping
control to the left of the view.

Grouping Dividing the data in a view into different groups
based on the values in one column. All rows where
the grouping column has the same value form one
group.

Grouping control A control that displays the grouping values in a
grouped view.

Importing Creating a view by importing data from an
external file, for example a CSV or Excel file.

Matching Placing one view alongside another to create a
new view. The resulting views contains only data
from both rows which has a matching value in a
matching column.

Scenario A series of steps that make up a data
transformation scenario.

Slicing Dividing the data in a view into different groups
based on sets of unique values in a column.

Stacking Placing one view above another to create a new
view.

Step One stage in a data transformation scenario. A step
performs an action on zero, one or two views and
outputs a new view.

Snapshot An intermediate stage in a data transformation
scenario, viewable by clicking on the step
corresponding to that stage.

View A logical organization of data in a data
transformation scenario.
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